A critical vulnerability has been discovered in WooCommerce prior to version 5.5 (the current version). You can read about it here, but they don’t give much info on what might happen. I dug into the code and I think that if someone exploited this on your store, they could have access to order, customer, and administrative information via a cleverly crafted search string.
It is extremely important that if you have WooCommerce installed you upgrade to 5.5.1 as a matter of urgency. Once these vulnerabilities become public, the baddies know about and start using them.Please don’t ignore this. And while you are at it, check that WordPress is at version 5.7.2
If you subscribe to the 123Host WordPress Management service, I have already upgraded WooCommerce for you.